Monday, November 04, 2019

And Yet More Wordpress Woes


I'm rebuilding Rational Review News Digest from scratch at another URL. Everything has been going swimmingly until ... this.

RRND consists of excerpts/blurbs for various news, commentary, and audio/video items each day. The post format, both on-site and in the email editions, looks like this:

Trevor Timm on The Scott Horton Show
Source: Libertarian Institute

"Trevor Timm talks about the inhumane and potentially life-threatening conditions Julian Assange is being held in as he awaits trial for violations of the Espionage Act." [various formats] (11/03/19)

https://libertarianinstitute.org/scotthortonshow/11-1-19-trevor-timm-on-julian-assange-and-the-threat-to-press-freedom-everywhere/

The new Wordpress installation is publishing this:

Trevor Timm on The Scott Horton Show
Source: Libertarian Institute

"Trevor Timm talks about the inhumane and potentially life-threatening conditions Julian Assange is being held in as he awaits trial for violations of the Espionage Act." [various formats] (11/03/19)

11/1/19 Trevor Timm on Julian Assange and the Threat to Press Freedom Everywhere

That doesn't work for me. At all. I generate my email newsletter from the web site content, and I need the URLS, not the titles of the pages the URLs lead to, to display.

I can't seem to find any setting to make it knock that shit off, nor are web searches for similar problems turning up anything useful.

My assumption is that Wordpress has recently (very recently, within the last 48 hours) updated, and that the update includes another horror show feature similar to, but not exactly like, one I've already disabled with a plug-in -- a "preview feature" that embeds actual videos instead of links to videos, etc.

Anyone got any ideas?

I'm near the point of looking for a more stable content management system to run my sites on. It feels like Wordpress issues updates every week and a half, and each one includes some new feature to fix stuff that isn't broken. In addition to a "disable embeds" plug-in, I also have to run one to let me use the "classic" editor instead of that idiotic new "block editor" that came in with the Gutenberg release.

UPDATE: Fixed. I think what happened is that when I enabled the "don't show previews" plug-in, it stopped doing that stuff, but that it did not automatically stop doing it for the first couple of posts that had already published. When I re-created the posts, they displayed correctly.

blog comments powered by Disqus
Three Column Modification courtesy of The Blogger Guide
Some graphics and styles ported from a previous theme by Jenny Giannopoulou